Hangs whenever i try to load prot_acc2tax-March2016.abin


#1

community edition 6.4.1, build 1 June 2016

whenever I try to load my diamond search, either in the java gui or using daa2rma and specify -a2t prot_acc2tax-March2016.abin

the process permanently hangs (using no cpu time)
this is using diamond v0.8.4.66 with a newly downloaded nr database

the daa2rma command would be like
megan/tools/daa2rma -i short2.daa -a2t data/prot_acc2tax-March2016.abin -o short2.rma

tried with and without daa-meganizer

the tabular output of the daa search result look something like
SRR1182511.15 gi|522028245|ref|WP_020539454.1| 67.6 37 12 0 3 113 100 136 4.4e-07 61.2
SRR1182511.15 gi|763367280|ref|WP_044224745.1| 67.6 37 12 0 3 113 100 136 4.9e-06 57.8
SRR1182511.28 gi|678329327|emb|CDW79700.1| 78.3 46 10 0 2 139 248 293 4.6e-14 84.7
SRR1182511.28 gi|403343435|gb|EJY71046.1| 77.8 45 10 0 2 136 252 296 7.9e-14 84.0
SRR1182511.28 gi|678307414|emb|CDW90944.1| 75.6 45 11 0 2 136 248 292 2.3e-13 82.4
SRR1182511.28 gi|146163742|ref|XP_001012227.2| 63.4 41 15 0 2 124 245 285 1.0e-08 67.0
SRR1182511.28 gi|929763905|ref|XP_014156933.1| 67.5 40 12 1 2 121 294 332 1.4e-07 63.2
SRR1182511.28 gi|255081132|ref|XP_002507788.1| 61.0 41 15 1 2 124 310 349 5.5e-07 61.2
SRR1182511.28 gi|551674168|ref|XP_005839839.1| 60.5 38 15 0 5 118 570 607 9.4e-07 60.5
SRR1182511.28 gi|612399352|ref|XP_007515195.1| 60.0 45 16 2 2 136 317 359 1.6e-06 59.7
SRR1182511.28 gi|1032149443|gb|OAO13425.1| 62.9 35 13 0 2 106 180 214 2.1e-06 59.3
SRR1182511.28 gi|1032149443|gb|OAO13425.1| 62.9 35 13 0 2 106 466 500 2.1e-06 59.3


#2

Is it a memory problem? MEGAN probably requires 8GB or more when processing DAA files and using an .abin file

Also, what OS is this on?


#3

running with 250GB on a 256 GB machine (20 core, 256GB shared memory, all 20 cores reserved so there are no other jobs using memory)

LSB Version: :base-4.0-amd64:base-4.0-ia32:base-4.0-noarch:core-4.0-amd64:core-4.0-ia32:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-ia32:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-ia32:printing-4.0-noarch
Distributor ID: RedHatEnterpriseServer
Description: Red Hat Enterprise Linux Server release 6.7 (Santiago)
Release: 6.7
Codename: Santiago


#4

also java version is 1.8.0_77 (i.e. java 8)


#5

I think I have found the problem. The latest versions use a new open source codebase and are missing a library (of stuff previously included in the code base, now separate)
Please upgrade to version 6.4.4