How to use the mapping file megan-map-Oct2019.db, and rma2info seem not work

Dear Dr. Daniel H. Huson :

I use the latest version of megan6 in Linux, firstly I use diamond alignment to generate the blastTab file, and then use the tools blast2rma to make taxonomy classification, but when assign the parameter --mapDB, which generate a error message, the code is below:

time  ~/software/megan/tools/blast2rma \
        --in ~/rgcIntegr/taxonomy/ncbi_nr/integr_ss.cdhit.NR.transeq.faa_dmnd_merge_tax \
        --out taxonomy/ncbi_nr/megan_tax_mdb.rma \
        --format BlastTab \
        --mapDB  ~/software/megan/res/megan-map-Oct2019.db \
        -ms 50 \
        -me 0.01 \
       -top 50

which throws an exception as such :

Version   MEGAN Community Edition (version 6.18.2, built 11 Dec 2019)
Copyright (C) 2019 Daniel H. Huson. This program comes with ABSOLUTELY NO 
WARRANTY.
Caught: jloda.util.UsageException: Illegal to use both --mapDB and ---acc2... or -- 
syn2... options, use option '-h' for help
       at megan/megan.tools.BLAST2RMA6.run(BLAST2RMA6.java:191)
       at megan/megan.tools.BLAST2RMA6.main(BLAST2RMA6.java:66)

real    0m0.796s
user   0m4.342s
sys     0m0.341s

when I change the parameter --mapDB to -a2t , which works for no warning, but if the generated .rma output file were passed to the rma2info tools, which output blank table, the code is below:

time ~/software/megan/tools/rma2info \
    --in taxonomy/ncbi_nr/megan_tax.rma \
    --class2count Taxonomy \
    --paths \
    --majorRanksOnly \
    --names \
    -o taxonomy/ncbi_nr/megan_tax_info.txt


less taxonomy/ncbi_nr/megan_tax_info.txt 

output as such:

taxonomy/ncbi_nr/megan_tax_info.txt: No such file or directory

could you help me some suggestions and potential reasons for this

Thank you

Dear Tank,

I have the same issue with you. Have you already solved that problem? Could you like to give me a guide to make the process works?

Thank you so much for your help

Regards,
Lulu

Hello Lulu:

Oliver replied to me that writes:” If you use diamond your next step should be to meganize the diamond alignment files (.daa) using the tool daa meganizer. The meganized diamond files can then be used with MEGAN straight away.”

In my view, updated Megan6 cannot support the blast2rma format and so subcommand rma2info
Did not work, you could try the diamond output as .daa, then piped to daa2rma and rma2info

By the way you could try alternative taxonomy classification software such as kraken2 or any other

Good luck for your metagenome research~ you’re welcome to any further question~

Dear Thank,

Thank you for your reply and your advice. Ah, I see that’s why the process didn’t work.

Actually I’ve tried to meganize .daa file output using MEGAN6 GUI and it seem works well. But, I wonder is there a differences between output that I got from meganize using MEGAN6 GUI and daa-meganizer using CLI?

Anyway thank you for your recommendation for using alternative taxonomy classification.

Regards,
Lulu

This is a bug in the blast2rma program. I will fix this and then upload a new release.

Also, consider generating DAA output with Diamond and then use daa-meganizer.

Datenschutzerklärung