Megan6 Linux throwing errors


#1

Hello,

I am attempting to run Megan6 from the command line on a Linux server. I have put all of the commands into a .txt file, as recommended. We have installed Oracle JRE and openjdk. I seem to get 2 different errors messages depending on whether openjdk or Oracle JRE is being invoked. I believe that when openjdk is being used, the program will start, but I get the following message to stdout:

Version MEGAN Ultimate Edition (version 6.4.19, built 19 Jul 2016)
Author(s) Daniel H. Huson
Copyright © 2016 Daniel H. Huson. This program comes with ABSOLUTELY NO WARRANTY.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Prism ES2 Error - nInitialize: glXChooseFBConfig failed
3D PCoA viewer not supported on this platform

When I use OracleJRE (by putting it into my path), the program doesn’t seem to start but I get the following in the error.log:

MEGAN fatal error:
java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel
Caught:
java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel
at megan6u.main.Megan6Ultimate.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:62)

I am trying to use Megan Ultimate Edition to test out the functionalities related to parsing of diamond output, with consideration of purchasing a license if we can get it to work well.

Thanks very much for your help!