Meganize error java.io

Hey guys,
I didn’t find a related previous topic, so I’m sorry if this has been asked befor.
I’m trying to do meganize on whole metagenome .daa files, but it keeps giving me the following error:
Info: Command completed (124s): meganize daaFile='C:\Users\carol\OneDrive\Área de Trabalho\DOUTORADO\Genes_phn\Metagenoma_diamond\Coleta 2019\diamond\01SR_1…
Executing: open viewer=SEED;
Executing: zoom what=fit;
Executing: open viewer=EGGNOG;
Executing: zoom what=fit;
Executing: uncollapse nodes=subtree;
Executing: uncollapse nodes=subtree;
Executing: show chart drawer=BarChart data=‘Taxonomy’;
Executing: open viewer=GTDB;
Executing: zoom what=fit;
Executing: uncollapse nodes=subtree;
Executing: open viewer=EC;
Executing: zoom what=fit;
Executing: uncollapse nodes=subtree;
Executing: open viewer=INTERPRO2GO;
Executing: zoom what=fit;
Executing: openUE viewer=KEGG;
Executing: zoom what=fit;
Executing: uncollapse nodes=subtree;
Executing: show window=MeganizeDAA;
Executing: load mapFile=‘C:\Users\carol\Downloads\MEGAN\megan-map-Jul2020-2-ue.db’ mapType=MeganMapDB cName=EC;
Executing: use cViewer=EC state=true;
Executing: load mapFile=‘C:\Users\carol\Downloads\MEGAN\megan-map-Jul2020-2-ue.db’ mapType=MeganMapDB cName=EGGNOG;
Executing: use cViewer=EGGNOG state=true;
Executing: load mapFile=‘C:\Users\carol\Downloads\MEGAN\megan-map-Jul2020-2-ue.db’ mapType=MeganMapDB cName=GTDB;
Executing: use cViewer=GTDB state=true;
Executing: load mapFile=‘C:\Users\carol\Downloads\MEGAN\megan-map-Jul2020-2-ue.db’ mapType=MeganMapDB cName=INTERPRO2GO;
Executing: use cViewer=INTERPRO2GO state=true;
Executing: load mapFile=‘C:\Users\carol\Downloads\MEGAN\megan-map-Jul2020-2-ue.db’ mapType=MeganMapDB cName=KEGG;
Executing: use cViewer=KEGG state=true;
Executing: load mapFile=‘C:\Users\carol\Downloads\MEGAN\megan-map-Jul2020-2-ue.db’ mapType=MeganMapDB cName=SEED;
Executing: use cViewer=SEED state=true;
Executing: load mapFile=‘C:\Users\carol\Downloads\MEGAN\megan-map-Jul2020-2-ue.db’ mapType=MeganMapDB cName=Taxonomy;
Executing: use cViewer=Taxonomy state=true;
Executing: update;
Executing: meganize daaFile=‘C:\Users\carol\OneDrive\Área de Trabalho\DOUTORADO\Metagenoma_MEGAN\04SR_1.daa’ minScore=50.0 maxExpected=0.01 minPercentIdentity=0.0 topPercent=10.0 minSupportPercent=0.05 lcaAlgorithm=naive minComplexity=0.0 useIdentityFilter=false readAssignmentMode=readCount fNames=EC EGGNOG GTDB INTERPRO2GO KEGG SEED longReads=false paired=false;
Meganizing file: C:\Users\carol\OneDrive\Área de Trabalho\DOUTORADO\Metagenoma_MEGAN\04SR_1.daa
Annotating DAA file using FAST mode (accession database and first accession per line)
NullPointerException: null
Command usage: meganize daaFile= [,…] [minScore=] [maxExpected=] [minPercentIdentity=]
[topPercent=] [minSupportPercent=] [minSupport=] [lcaAlgorithm={naive|weighted|longReads}] [lcaCoveragePercent=] [minPercentReadToCover=]
[minComplexity=] [useIdentityFilter={false|true}]
[fNames={EC|EGGNOG|GTDB|INTERPRO2GO|KEGG|SEED…} [longReads={false|true}] [paired={false|true} [pairSuffixLength={number}]]
[contaminantsFile=] [description=]; - Meganize DAA File
IOException: null
Error: Execute failed: java.io.IOException

However, when I do it for specific genes .daa files, it works fine. Don’t know what to do here. Can anyone help me?

Thank you.

Could you try changing the name of your directory from “Área de Trabalho” to something that doesn’t contain any accents or spaces… That might be causing the problem.

Thanks for the reply, but it didn’t work.
I’m not sure what’s causing it.

Datenschutzerklärung