No reads assigned when using megan-map-Oct2019.db.zip

Hi Daniel, first of all, thanks for your work with Megan. With 6.18.0, I do the following:

  • generate diamond daa file (blastx fastq to diamond nr DB, here 2 sample lines from diamond view -a):

m181204_201404_42243_c101474132550000001823318602141954_s1_p0/394/ccs gi|489855549|ref|WP_003759213.1| 79.5 112 20 1 921 1256 17 125 1.6e-40 174.5

m181204_201404_42243_c101474132550000001823318602141954_s1_p0/394/ccs gi|394329057|gb|EJE55184.1| 82.0 100 18 0 951256 1 100 3.3e-38 166.8

  • meganize DAA file (file -> meganize DAA file -> select file to meganize)
  • select the daa file above and load the megan-map-Oct2019.db as database (taxonomy -> loadMeganMapDB mapping file)

In the end, not a single sequence is assigned. Any ideas what I am missing? Any help appreciated.
Best,
Giancarlo

The problem is with the header line in your reference database:

To speed things up, the new mapping approach implemented in MEGAN 6.18.0 (but please use the update 6.18.1) does a lookup on the first word in the header line, which in this example is
gi|489855549|ref|WP_003759213.1. For this to work, you would have to strip away the
gi|…|ref| from all headers before running through DIAMOND.

MEGAN provides to mapping modes, FAST mode and EXTENDED mode. EXTENDED mode should be able to handle your files as is, but it will be much slower than the FAST mode.

Please give that a try and let me know how it goes.

Thanks a lot Daniel. It worked with v 6.18.0 (just diamond-viewed .daa, removed the unnecessary stuff and imported as blast).
###sample lines

M01106:247:000000000-BLV4F:1:1101:16413:1371 CAR86198.1 91.4 81 7 0 300 58 25 105 2.9e-34 151.4
M01106:247:000000000-BLV4F:1:1101:16413:1371 CCB82280.1 89.0 82 9 0 303 58 24 105 4.9e-34 150.6

However the same file doesn’t work with v6.18.1.
Best,
G

PS: in the sense that nothing gets assigned.

could you give me a small file of alignments that works with 6.18.0 but not with 6.18.1

Datenschutzerklärung