Problem in importing tabular blastp output file


#1

I obtained rma files from tabular blastp output files so far, but now it doesn’t work.
I wonder if that’s related to updating megan to current version(V6.6.0). But I uninstalled the previous version and I can’t confirm that.

I specify the blast output format by “-outfmt “6 std staxids stitle qcovs””.
And the output is as follows.

hi_all_scaffold8_1_gene8 gi|763169092|ref|WP_044048745.1| 99.33 297 2
0 1 297 6 302 0.0 573 666509;1284658 membrane protein [Planktomarina temperata] 100

I imported the blast outputs in megan6, using mapping files in megan6 download page (e.g. prot_acc2tax-Aug2016.abin).
It worked well so far. But now no reads are assigned.
(I don’t know if it has relation, but I found that it says “mode=Classifier” in the bottom of megan window, though I choose blastp in import blast file menu.)

Now I’m trying latest blast(ncbi-blast-2.5.0+), and the output is as follows.
In this case, no reads are assigned, too.

hi_all_scaffold8_1_gene8 WP_044048745 99.327 297 2 0 1 297
6 302 0.0 573 666509;1284658 membrane protein [Planktomarina temperata] 100

If you know why it doesn’t work, please advise me.
I also would like to ask which category should be selected in blast tabular file, and which version of blast is recommended for megan use.


#2

The only tab format that MEGAN can import is -m8, which your format isn’t
I recommend using DIAMOND rather than BLAST for aligning reads against a protein reference database


#3

Thank you for reply!
I’ll try to use DIAMOND.