[Solved] MEGAN6 alignment viewer not displaying all alignments

Hello,

I’ve been looking at some shotgun data that has been run through MALT (v038) on BLASTN mode to the full NCBI NT Database (from February 2016). MALT parameters: -id 85, -top 1, -supp 0.01, -mq 100.

When loading the RMA6 file into MEGAN6-CE (v6.7.18), and load the alignment viewer on a specific leaf node, not all the alignments that are supposedly on the node are displayed in the viewer. This also occurs on a colleagues version of MEGAN-CE (v6.4.0).

I include a link with an example RMA6 file and screenshots from v6.7.18 here.

To reproduce: If you open the RMA6 file and look for the ‘Ceratotherium simum simum’ node, it is indicated that there are 280 (summarised) hits. If you open the ‘Inspect’ window on that node, you can see the BLAST output of all 280 reads. However if you open the alignment viewer on the same node, there are only available 40 reads to be viewed across three reference sequences.

Is this a bug, or is there some additional filter when using the alignment viewer?

Kind Regards,
James

Dear James,

the most likely explanation is that, by default, the alignment viewer only displays a reference sequence if there is at least 10 reads aligned to it. So most of your reads align to reference sequences that attract less than 10 reads.

You can change the threshold to 1, say, by adding the following line
to the MEGAN preferences file Megan.def :

MinReadsInAlignment=1

On linux, find the file here: ~/.Megan.def, on MacOSX here: ~/Libary/Preferences/Megan.def, not sure where Windows puts preference files.

D

Thanks Daniel, yes that solved my problem.

Datenschutzerklärung