Taxon not assigned via MALT


#1

Dear MEGAN community,

For some reason, MALT does not want to assign a particular taxon (Anaerolineacea sp oral taxon 439). I run my data through MALT, and open it in MEGAN to find all the reads that should be assigned to this taxon in the “not assigned” bin. Upon inspecting the alignments, they pass my desired LCA parameters, but are somehow not assigned:

22 PM

I can fix this by recalculating LCA parameters in MEGAN, but I have >500 samples, and don’t want to have to do this separately for each file…

Any help would be greatly appreciated.
Kind regards,
Raphael


#2

Please show me the exact command line options that you used to run MALT.
Then also show me the parameters used in MEGAN that fixes the problem.


#3

Hi Dan,

(MALT-run)
./malt_0_3_8/malt-run -i 4_Input_Data/* -supp 0.1 -wlca true -b 44 -e 0.01 -o 7_Done/RMAs/ -iu -ou 7_Done/Unaligned/ -d 3_Indices/Arch-Bact-RefSeq-GCS-27-7-17 -mem load --mode BlastN -t 32 -v

In MEGAN, I open the Change LCA Parameters window, and the LCA parameters chosen in MALT are already there. To fix, I hit ‘Apply’.

This is also the case when I use a different MALT index (based on the BLAST 2017 nt – with the latest 2017 acc-2-taxonomy.abin file).

Cheers,
Raphael