Which Java version?

We wish to upgrade to Megan 6.18.3 on Linux. I see that “MEGAN 6.16.0 now runs under Java 12 and comes with JavaFX bundled”. But Oracle say that Java SE 12 has reached end of support (https://www.oracle.com/technetwork/java/javase/downloads/jdk12-downloads-5295953.html)

Which version of java should we use?
Do we need the JDK or just the JRE/SE?

You can use Java 11 or higher.

Datenschutzerklärung